DIY Electronics Message Board
Register  |   |   |  Latest Topics
 
 
 


Reply
  Author   Comment  
bmwbiker69

Registered:
Posts: 2
Reply with quote  #1 
I#ve bought the K150 for programming a lot of 12C508A.....

But I can't!?!

Every time I got fuse error.
before programming I#m checking the fuses manually - everythin is OK.

After burning and error-message I read read the rom from chip-but the fuses are always not like I have programmed and contolled several times before pushing the programm-button?

For verification these Issue I use the 12F508 - and every time the programming with the same code went fine with positive result!

Please give me a sollution!

Best regards,

bmwbiker69
Frank

Moderator
Registered:
Posts: 1,889
Reply with quote  #2 
What version of Micropro/Microbrn are you using?

The latest version (P18A) is contained in DIYpack25EP. When you unzip you will see a 'read_me' file that contains stating that some bug fixes have been done to 12C50x parts (among others). Maybe this will solve your problem.

It also talks about fuse setting for 12-bit core parts (I assume 12C508 is a 12-bit core part - I am not a PIC user). It says that the software does not display the correct values for the fuses however embedding the fuse settings in the code does program them correctly. I think this applies to the P18 protocol in previous versions of Microbrn (P018).

Be aware that all development on these programmers has stopped (many years ago). Any bugs will not be fixed.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Thank you for visiting.